0%

gyp no xcode dected报错

在安装baidusitemap插件式,macOS版本高的用户可能碰到如下报错:

gyp: No Xcode or CLT version detected!

原因很简单,缺了Xcode的cli插件,我们把它装上就好了。

1
sudo xcode-select --install

执行完了好像还是不行?遇到如下报错:

1
xcode-select: error: command line tools are already installed, use "Software Update" to install updates

这还不简单,卸了重装就好了。

1
2
rm -rf /Library/Developer/CommandLineTools
xcode-select --install

执行提示权限不够就加上sudo就好了!

本文标题:gyp no xcode dected报错

文章作者:DY

发布时间:2020年02月08日 - 22:02

最后更新:2020年02月23日 - 19:02

原始链接:https://hzdy.github.io/gyp%20no%20xcode%20dected%E6%8A%A5%E9%94%99.html

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。